Skip Navigation

"Next" & "Previous" go in wrong order

Travel Forums System Talk "Next" & "Previous" go in wrong order

1. Posted by VANagain (Budding Member 5 posts) 2y

The "Next" & "Previous" links on my blog entries do not go thru the entries in the right order! Instead of going in order of Entered Date it seems to go based on the actual order that I did each post. This is a historical blog and I did not add each entry in chronological order. The table of contents sorts in the order I want (Entered Date). As I go from page to page with "Next" & "Previous", I can see that each entry has a URL ending with a number, and that seems to be the order that "Next" & "Previous" use.

Is there a way to fix this?!

Thanks.

2. Posted by Peter (Admin 5807 posts) 2y

Hmm, I'm having hard time finding the problem. I started with your first post and hit Next all the way through all your entries.

The post date increased with each one of them exactly as I would expect them to behave. Can you link to the exact page where the Next/Previous links are wrong?

Peter

3. Posted by VANagain (Budding Member 5 posts) 2y

I should have posted again, saying I figured it out. It turns out the Next and Previous links do not go by dates at all. They go by the URL page numbers. Looks to me like the code for Next says go to the next higher page, and Previous goes to the next lower page. Since I did not enter each entry in order, this was all messed up.

I had to recreate each entry, from first to last. It wasn't too much work. I opened two browser windows, edited the original, copied and pasted it all into a new entry post. Then I deleted my old entries. As long as you enter each entry in order, these links will work as expected. Not great, but at least it worked.

4. Posted by Peter (Admin 5807 posts) 2y

Ah, I see - you fixed them up :) The next/previous links really should operate by the same order as in the sidebar which is what you were expecting. The fact it's not doing this is a bug.