Skip Navigation

Photos pixelated

Travel Forums System Talk Photos pixelated

1. Posted by NicoleandJens (First Time Poster 1 posts) 1y

We have been uploading pictures into our blog for a while and noticed that sometimes the quality of the pictures becomes really bad (pixelated photos) after uploading. We have had uploads where this problem did not occur but in most cases it did.How this can be fixed? We would like to have the same quality of our pictures in all of our blogs. Usually the size of the pictures we are uploading is around 1-2 MB and the quality is good so I donĀ“t understand how the quality goes down to significantly after uploading them. Thanks for your help.

Post 2 was removed by a moderator
3. Posted by Peter (Admin 5789 posts) 1y

I looked into a similar issue recently for another user and the problem specifically happened when the photo was uploaded and then rotated on Travellerspoint. Does this match your experience by any chance?

I did add a little code which helped with this somewhat, but the problem actually boils down to the way the photo is resized on uploading. It's not particularly good. Mostly it's ok, but it seems to really fall apart when rotating some photos for some reason.

The workaround is to upload and tick the box to "Save a backup on Travellerspoint" when you do so. Downside to that is that it takes a lot longer.

An alternative workaround is to find a way to rotate the photo prior to uploading so that it doesn't need to do that again after uploading. That's if the rotating issue is in fact what is causing your issues.

4. Posted by Utrecht (Moderator 5595 posts) 1y

Quoting Peter

An alternative workaround is to find a way to rotate the photo prior to uploading so that it doesn't need to do that again after uploading. That's if the rotating issue is in fact what is causing your issues.

Actually, that doesn't help. At least not in my case.
I don't have issues with pixelated photos as I tick the 'save on TP' button.

I do, however, rotate photos before uploading them on TP. But still it somehow shows them in the original position.

After the upload is complete I rotate them and click the safe button: this causes problems too, as it sometimes gives an error and I have to save them again, either as a whole or individually later on. I guess there is some bug in the rotating section of TP lol

Cheers

[ Edit: Edited on 02-Dec-2014, at 08:03 by Utrecht ]

5. Posted by Peter (Admin 5789 posts) 1y

With the example I looked at last time, the photo had been rotated before hand, but the photo included incorrect metadata about the rotation.

I'm not sure what software was used there, but if you have an example of a photo that is behaving this way, feel free to send it through to me and I'll test it out.