Skip Navigation

"You need to choose a location first"

Travel Forums System Talk "You need to choose a location first"

1. Posted by Yuman (Budding Member 3 posts) 33w

Good evening,
we've been using this website for a very short time, I have a problem with locations that the map or planner tools don't recognize. A window keeps popping up, that says "you need to choose a location first" and I can't save the location.
Do you have the same issue, and how can we get around it?
Thank you.

2. Posted by Peter (Admin 5790 posts) 33w

This particular error happens when we don't have the location data needed to create the stop. The most likely scenario is that you typed the location name, then moved on to the next field without selecting one of the locations provided in the auto complete. You need to select a location in the autocomplete, because that sets the latitude and longitude of the stop and removes any ambiguity about location you are looking for.

Does that help explain the problem and how to avoid it?

3. Posted by Yuman (Budding Member 3 posts) 32w

Thanks Peter for your answer.
I can see that the "location" field works with auto complete. Sometimes our locations do not show among the locations provided by the auto complete: is there a way to create them?

4. Posted by Peter (Admin 5790 posts) 32w

Picking a place nearby is the best bet. You can then actually drag the marker to the correct location if you need to.

5. Posted by katewilliams (Budding Member 3 posts) 32w

I have the same problem, what did you end up doing?

6. Posted by Yuman (Budding Member 3 posts) 32w

It worked: I located another organization near the address I was trying to add and saved it. Then I added the name of "my" organization and saved, it worked. Then I changed the number in the street (2975 instead of 2900) and save, it worked.
In the end it means that it is possible to add an address that is not in the auto complete menu, but it requires extra research with another map. :(