Skip Navigation

Problems mapping travels - help!!

Travel Forums System Talk Problems mapping travels - help!!

1. Posted by claireh (Respected Member 318 posts) 9y

It's showing stops in the middle of the ocean and things and some of my stops are completely missing from the map. It's confusing me no end.

If anyone is an expert on this matter, I'd appreciate it if you could have a quick look and tell me where I'm going wrong (or what the system is doing...!) Thanks

2. Posted by Sander (Moderator 4834 posts) 9y

Looking at Malaysia, the map doesn't know where your "Pulau Pangkor", "Cameron Highlands" and "Kuala Lumpur" are located, so it puts them in the middle of the country, rather than at the exact coordinates they should have (and then the next time fills in the coordinates of the middle of the country).

The way to make this not happen is to, when writing the name of the location, click on the autocomplete suggestion that appears directly underneath the location. That will automatically fill in the correct latitude and longitude. (You can also select it by using the arrow down key and then hitting enter. That's probably the easiest way to fix right now. Click in the location name field, hit the arrow down key, wait half a second for the list of possible locations to load, click on the correct one.)

Alternatively you can zoom in on the map until you can identify the right location of these cities, click on the "select on map" 'button', and then click on the right location on the map. That will update the coordinates for the city.

Looking at your SE Asia & India itinerary here, each of the cities in the yellow block which doesn't have the country listed behind it (so "Koh Pha Ngan", rather than "Bangkok, Thailand") currently doesn't have the correct coordinates set.

I've been seeing a lot of people with cities in the middle of the country, so the need to click on them in the autocomplete list (or to otherwise have the correct latitude and longitude filled in) is apparently not clear enough. I haven't yet been able to come up with a good idea on how to make this clearer (I don't want to automatically match with the top suggestion, as that'll make it even more confusing why it sometimes works and sometimes doesn't if our map uses a slightly different spelling or if there's multiple cities all with the same name - but I don't know yet what would be better to do. Maybe I can create a "did you mean?" dialog in a way which wouldn't be too annoying.)

[ Edit: Edited on Mar 11, 2007, at 1:42 AM by Sander ]

3. Posted by Sander (Moderator 4834 posts) 9y

Okay, so doing some testing myself, it looks like the autocomplete suggestions are somehow taking much longer to appear than when we went live, and I can thus easily imagine a lot of people not even seeing them, let alone clicking on them. :(

edit: I just cut the time needed for these autocomplete suggestions to appear on our test server in half. I'll see if I can the same done on the live site.

[ Edit: Edited on Mar 11, 2007, at 2:59 AM by Sander ]

4. Posted by claireh (Respected Member 318 posts) 9y

Grand, I'll try again! Thanks guys...