Skip Navigation

Errors with wiki destination guide

Travel Forums System Talk Errors with wiki destination guide

1. Posted by GregW (Travel Guru 2635 posts) 9y

Yesterday and today I have been getting errors with the wiki destination guides again. Today it was with the WHISTLER article. Yesterday it was with Nunavut.

Yesterday I thought it was related to be not correctly closing a link on a ref tag, and once I did that it seemed to clear up. I checked the Nunavut page after the error, and it had not uploaded by article (first pass).

Today I thought it was because I had a hanging photo tag (deleted the ] end bracket), but even after I fixed that, I was still getting the errors. For the Whistler article, even though I got the error, it did upload my article.

Greg

2. Posted by GregW (Travel Guru 2635 posts) 9y

Another interesting point - the Whistler article is now there, but it does not show up as being created / editted in the RECENTLY UPDATED PAGES list.

3. Posted by Peter (Admin 5789 posts) 9y

It seems the usual reason for these errors is some overly sensitive code of ours that doesn't correctly detect when something is a link. On the Whistler article, there is a link to http://www.busonline.ca/regions/whi/schedules/map.cfm?region=0&

I suspect that the stray ampersand at the end is enough to cause problems, because instead of detecting that it is an internal link the code thinks it is the title of another article in the guide.

I'll log the bug.. it's a tricky one though, because it's very hard to cover all the weird and wonderful types of urls in the world.

4. Posted by GregW (Travel Guru 2635 posts) 9y

Well, in the interim, I've changed the link to...

http://www.busonline.ca/regions/whi/schedules/map.cfm

...with no stray &s, and no more errors when saving it.

Greg