Skip Navigation

How to make custom template the default?

Travel Forums System Talk How to make custom template the default?

1. Posted by patsybrel (Full Member 3 posts) 9y

Hello,

I edited the Blog Template / Stylesheet / CSS for my Travellerspoint site [My Blogs > Patsy et Brel en Amérique du Sud ... > Template > Edit Template] to put in a new background image for the page by editing the #wrapper id.

I am using the "Scribble" template designed by John Oxton as a base.

I clicked on "Update Template" to save the changes, and got the "Template Change Successful / The change has been made." feedback message.

But when I click on the "show me my new blog" link, the changes were not there.

If I view the css, for the page, the old css (http://www.travellerspoint.com/blog/9.css) is still there without the changes.

However, if I choose the "Default" template using the drop-down "Change Style" menu on the Web page, then the changes are visible.

I want people who come to my site to see my customized template with the new background. When I go to the "Template -> Choose a Template" page in "Blog Management", the "Default" template that I have control over is not given as an option.

Is there something I am missing!?! How do I ensure that users will see the customized template?

- don for PatsyBrel

2. Posted by Peter (Admin 5789 posts) 9y

Hi Don, the change you made did actually do what you wanted. What probably happened is that you had selected the scribble design in the dropdown on the blog at an earlier stage. That would have been remembered by the system, so it wouldn't be showing you the default. When I checked just now, not having visited your blog before, it showed me your custom design (nice work btw ;))

3. Posted by Sam I Am (Admin 5588 posts) 9y

Just to clarify what Peter said, since it didn't make much sense to me at first :) , on the blog users can choose to 'Change Style' which will set a cookie and mean they view your blog in that style from then on. I don't think it's used much, but it can be nice if you are having a problem reading a blog based on the style chosen and the font size/color that goes with it. Deleting cookies on your computer should show you what the default is (or you can just choose Default from that dropdown and save it to override the existing one).

If you don't want to allow users to be able to change the style, you can turn this off in your blog settings area.

And I'll second Peter that it's a nice re-design :)

4. Posted by patsybrel (Full Member 3 posts) 9y

Thanks Sam I Am and Peter for the explanations! Much obliged. Good to know about the cookie. Should have thought of that :)

- don for PatsyBrel