Skip Navigation

Bulk Photo Upload problem

Travel Forums System Talk Bulk Photo Upload problem

1. Posted by Gelli (Travel Guru 2457 posts) 7y

Sorry guys, i seem to be causing allsorts of problems these days. Blame it on Linux, Satellite feeds, obscure islands and my general incompetence.

I can't get the bulk photo loader to work (i have before, but not from this machine). I can find the folder without problem, but it appears empty. However, If i go to single photo uploader, it lists all the photos without problem. All are Jpgs. As i have quite a number to upload, it could take some time doing it singly.

Any ideas?

2. Posted by Sander (Moderator 4808 posts) 7y

The multiple file uploader restricts the images shown to those which have a mime type of image/*. It's possible that your jpgs for some reason don't have that (maybe due to bad file permissions since the files came from your camera (e.g. they'll appear to be executable)). I don't know what file picker dialog you're seeing, but what I can do on windows is to manually enter the filename as *.* and hit enter, after which _all_ files will show (as opposed to just those recognized as images). If an equivalent action is possible for you, try that.

If not, browse to the files (just on your computer, not through the browser) and check their properties, unchecking the executable bit if it's set. (Or if you're familiar with the commandline, chmod -x on them to do the same.) See if they show up now.
Alternatively, to test my hypothesis that something like that is indeed going on, try creating a new jpg with any image editing program that's present on your eee, and see if that one does show in the file picker dialog. If it does, that makes it that much more likely that it's a permissions issue.

3. Posted by Gelli (Travel Guru 2457 posts) 7y

Hmmm. Interesting-ish. Ok, none are executable. I resaved one, tweaking the resolution and it suddenly appeared. The permissions changed (so nowrite for group or others) and so i then changed the rest of the permissions to the same, but they still didn't show up.

I have no manual input option, so can't try *.* . And on paint, i can't save as a jpg (i can as a png which appears fine to be able to upload). It's a bit odd.

It seems i can get around it by re-saving all files individually at the moment which i'll do. And i'll then investigate permissions etc a bit later in more detail to see if i can work out a better way

Cheers

EDIT: have noticed that on resave, ".JPG" becomes ".jpg". I then changed one manually, and it also appears. So it seems to be solely because .JPG is i capitals. Does that help any of the techy lot to workout what's going on?

[ Edit: Edited on Oct 29, 2008, at 5:09 AM by Gelli ]

4. Posted by Sander (Moderator 4808 posts) 7y

Yeah, the Linux filesystem is case sensitive. There's a mapping in the system that tells it that all .jpg files have the mimetype image/jpeg. That mapping evidently doesn't exist for .JPG files. You can either try to add that mapping (I don't know where to look; there might be an option for it under the preferences of your file browser), or rename all your .JPG files. Google tells me the following command (run from the commandline in the relevant directory) should work:

for f in *.JPG; do mv $f `basename $f .JPG`.jpg; done;

(Try that in a test directory first, obviously.)

To avoid problems in the future, you should also be able to tell your camera to save files with lowercase extensions (at least I remember having seen that option on more than one camera, though that's of course no guarantee yours has it).

5. Posted by Peter (Admin 5789 posts) 7y

I just added the uppercase versions of extensions to the filter, so theoretically it might work on Linux now as well. Just be sure to hit refresh when you're on the upload page to load the updated javascript.

Let me know if it works. Man, I need to get a hold of a Linux box!

6. Posted by Gelli (Travel Guru 2457 posts) 7y

Yup, works fine. thanks