Skip Navigation

RSS not picking up latest blog entry

Travel Forums System Talk RSS not picking up latest blog entry

Page
  • 1
  • 2

Last Post

1. Posted by GregW (Travel Guru 2635 posts) 5y

Not sure if this is a problem with feedburner or TP, but my RSS feed isn't showing my latest blog entry (published last night - now about 18 hours ago).

Feedburner link

vs.

Blog

Thoughts?

Thanks,
Greg

2. Posted by Sam I Am (Admin 5588 posts) 5y

Hmm, yes, I can see what probably is the problem... having a look at it a little more closely now!

Post 3 was removed by a moderator
4. Posted by Sam I Am (Admin 5588 posts) 5y

This was an interesting one :)

There seems to be a small difference in timestamps between the database server and the web server. I don't think this normally would have caused this problem, but I think there was also a one hour time change on the day you posted that entry? In any case, essentially the feed itself is cached, with a new one only being generated when there is a difference between the database time of the last update, and the timestamp allocated to the cached file. In this case the difference was the wrong way around, basically indicating that the cache didn't need to be cleared.

I'm still trying to figure out how that happened other than my theory regarding it being a fluke coming down to timezones, but have fixed it for now by at least making sure that the 15 second time difference between the two servers can't cause this...

I'll investigate further tomorrow as there are some other small bugs but it's working now! Added in post tags as well for good measure.

Sam

5. Posted by GregW (Travel Guru 2635 posts) 5y

Hmmm. I posted it on the weekend, but put it for a delayed publish date. Not sure about time changes - at least the time didn't change here in the UK, for it had done that a month earlier. Perhaps a time change some place else.

I have no idea what post tags are.

6. Posted by Sam I Am (Admin 5588 posts) 5y

Ah, perhaps it's the delayed posting that caused that. In any case, I think I've fixed what caused it so it shouldn't happen again. The 'post tags' are just the tags you add to your blog posts. They'll now show up in feed readers as well :)

Mind you, still a small issue here that I'm aware of, but running that one by Peter before putting in a change!

Post 7 was removed by a moderator
8. Posted by GregW (Travel Guru 2635 posts) 5y

I think the issue with the future dated entries may still be happening, as I future dated an entry for yesterday, and it has not appeared in my RSS feed yet.

9. Posted by Sam I Am (Admin 5588 posts) 5y

ARGH!! It's obviously the future publishing that's causing this, but I can't for the life of me figure out why. I've passed it on to smarter people than myself (read: Peter)...

10. Posted by GregW (Travel Guru 2635 posts) 5y

Just posted a new entry (not future dated), and the RSS feed has picked up both entries - the new one and the previously posted one.