Skip Navigation

linking with facebook

Travel Forums System Talk linking with facebook

1. Posted by dcd (First Time Poster 1 posts) 5y

would like to have facebook friends view a link to my TP page. however when tested it seems friends can edit my settings and change blog entries. how do i give them a link that takes them directly to my blog rather than to the page showing all blog entries with edit capabilities?

2. Posted by Sander (Moderator 4808 posts) 5y

Woaw, they really shouldn't be able to edit any of your settings or anything - if you link them to your blog management pages, they should get a login page, or if they're logged in already, they should get a warning that they don't have any privileges for editing your blog. (I just tested this, and this still works as intended as far as I can see. The only way I can see what you're describing happening is if you let them use your own computer while you're still logged in. Or maybe your friends only saw the login page, told you about that, and then you saw edit links when you yourself went to that page? If neither of that is what happened, could you please send a private message to Peter (one of the admins here) with the exact link you gave your friends that allowed them to edit your blog?)

The url for your blog to give to other people is http://dcd.travellerspoint.com/, which you can find on your profile, or with the "view blog" tab in the top right corner of the blog management pages.

Btw, you can also automatically publish your blog entries to facebook, which means they show up in your news feed there. I don't use facebook myself, but I assume this would allow any of your friends to see as soon as you published a blog entry, complete with link to it.

[ Edit: Edited on 01-Jan-2011, at 11:00 by Sander ]

3. Posted by Peter (Admin 5789 posts) 5y

Hi dcd, I suspect you shared your admin page with them via the share link at the top of our site. While this does indeed point to your admin area, it will not allow them to edit your entries, since they would need to be logged on to travellerspoint as you to actually access the area. It will instead give them a message they they have insufficient privileges .

Of course , when YOU click on that link it will indeed allow you to see everything and edit anything, but that's only because you ate logged in.

As sander said, the best is to add the app that we have on fb that will automatically post you new entries to your wall.

Hope that makes sense :)

edit: here's the link to the Facebook app

[ Edit: Edited on 03-Jan-2011, at 02:33 by Peter ]

4. Posted by Andrea R (Full Member 15 posts) 5y

Hi, I haven't been able to successfully link my blog to Facebook and am running out of ideas.

When I use the Travellerspoint app on FB, I put my blog url in the editable field and click the button, and all that happens is the page reloads.

As an alternative, when I go through the FB Notes app and set it to import my blog, it only works as a one-off. That is, it successfully imports whatever is in my blog at that point in time, but nothing for later posts. It seems to 'forget' my import settings. This basically means that manual import works but not automatic.

Any ideas?

5. Posted by Sam I Am (Admin 5588 posts) 5y

Hi Andrea,

Just to be sure, rather than adding the whole URL in the editable field, you should only be adding the bit at the beginning, ie. andrea-r. Upon hitting submit, that should show a yellowish bar at the top. If it's set up correctly, visiting http://apps.facebook.com/travellerspoint/ will also show that yellow bar saying "Your blog http://andrea-r.travellerspoint.com is currently set to publish entries to your News Feed".

The Notes option should also still work, but it's not as fast to update as the app, and it doesn't always publish to your news feed either if I'm not mistaken.

Please let me know if you are still having problems!!

Sam

6. Posted by Andrea R (Full Member 15 posts) 5y

Thanks Sam, that worked a treat. Problem was I had been trying to get it to work with the http:// bit at the beginning.

cheers,

andrea

7. Posted by Sam I Am (Admin 5588 posts) 5y

Quoting Andrea R

Thanks Sam, that worked a treat. Problem was I had been trying to get it to work with the http:// bit at the beginning.

cheers,

andrea

Great! And erm, I totally understand why... there should be a http:// in front of that box to clarify that that isn't needed! :)

8. Posted by Peter (Admin 5789 posts) 5y

Just added the "http://" in there to help clarify the situation!