Skip Navigation

Newsletter and e-mail notifications not received

Travel Forums System Talk Newsletter and e-mail notifications not received

1. Posted by Hien (Moderator 3906 posts) 5y

Hey guys,

I have not been receiving any newsletter or e-mail notification (forum thread subscription and private messages) for almost two months. The last one I got is a PM notification, received on 29/01. I checked my profile and all information and subscription status remained the same as they were. There was nothing from TP in my e-mail junk folder either. Is there something wrong with the connection between my mail server and TP's? Or could it be something broken in TP? If it helps, the last e-mail notification received was from Isa.

Cheers,
Hien

2. Posted by Isadora (Travel Guru 13926 posts) 5y

Oh sure, blame the innocent.

I've been getting all of my notifications. Didn't know I was so selective in my destruction...

3. Posted by Sam I Am (Admin 5588 posts) 5y

Hey Hien, okay, so as per our testing a few minutes, seems it must be something on your end blocking travellerspoint emails :(

If anyone else is having this problem, we'd love hearing about it!

4. Posted by Hien (Moderator 3906 posts) 5y

Yup, my mail server seems to be blocking TP mails. I've filed complain asking them to fix it really quick or I'll change to a different host.

5. Posted by Hien (Moderator 3906 posts) 5y

I played Sherlock Holmes for e-mails and found where the problem lies.

I sent a test mail from a different mail server using the sender as noreply[at]travellerspoint.com and I received it. This shows that my mail server is not rejecting TP e-mails because of the domain name as we previously thought the case was.

So I turned off the spam filter on my mail server and I'm able to receive TP e-mails again. Looking at the header, my mail server detected a failed DKIM and slapped it with a spam weight of 30, which is the same weight as having it sent from a blacklisted server. I checked the older e-mails from TP and they all have failed DKIM too, but back then I received them without problem. I checked with my host and they explained that they've only recently enforced the standards for DKIM, SPF, etc. If an e-mail incorporates these features, it must pass or it'll be rejected.

[ Edit: Edited on 25-Mar-2011, at 12:02 by Hien ]

6. Posted by Hien (Moderator 3906 posts) 5y

Just an update here. Peter has fixed the DKIM problem. My mail server is happily receiving e-mails from TP again!