Skip Navigation

RSS pushing does not work

Travel Forums System Talk RSS pushing does not work

1. Posted by Sandalsand (Respected Member 45 posts) 1y

I published an entry 20 hours ago. It is still not showing in RSS readers, it has not been pushed from Travellerspoint. What's happening?

2. Posted by Sander (Moderator 4420 posts) 1y

If you're talking about the blog entry "A Lifetime of travelling"; I strongly suspect that that has been published at some point in the past (its "entry" id is 6, while you're up to 430 entries in total). The atom standard specifies that the publication date of a blogpost should never change after the first moment of publication, and the feed only shows the latest 20 (10?) published entries. The feed does show if one of those entries gets an update after publication - which would be reflected by feed readers - but since this particular entry is so old it isn't in the feed in the first place, feed readers also don't show it.

If you're talking about the blog entry "Travel Guidebooks", then I don't know what caused the delay, but it is showing up now.

3. Posted by Sandalsand (Respected Member 45 posts) 1y

I was talking about the "Travel Guidebooks" entry, and it is showing up now. It took its time though.

The other entry you mention "A lifetime of travelling" is an old one yes, but it is continously being republished (and its updated) to force it into being a permanent "front page" to my blog. This is a way to buypass the constrains of Travellerspoint, but its working. I'm glad you don't resend that particular page to feed readers.

4. Posted by Peter (Admin 5522 posts) 1y

I did make some changes to how the feeds are published last week - mainly in how they're cached. It could be there's a bug in there causing them to not refresh as quick as they should. Will need to investigate and test a bit more.