Skip Navigation

Adding trip and using map still a disaster

Travel Forums System Talk Adding trip and using map still a disaster

1. Posted by Utrecht (Moderator 5557 posts) 1y

Hi,

Adding another trip keeps on being a pain in the ass, nothing more nothing less.

1. Dragging a location does not work
2. Regularly he does not recognize locations, even though he suggests the places when typing them myself
3. Insert a location after a specific other one in the middle of the trip keeps on placing that one at the end. Then when clicking a few buttons and going back it appears to be there.

Basically, the whole thing doesn't seem to work properly. The system gets confused quite easily unfortunately, which is a shame.

On a side note: would it be possible to have the option to just add a year, and maybe a month if you know that one, instead of having to give the specific dates of trips. I remember some short weekend trips but not the exact date, but I can not add just a year or month. Kinda like timeline on facebook would be nice. The reason I ask is that it is much more easy to check my trips in a chronological order instead of them listed randomly, especially the older ones. Thanks.

Mike

[ Edit: Edited on 23-Mar-2013, at 13:39 by Utrecht ]

2. Posted by Sander (Moderator 4428 posts) 1y

Try picking a date, and then manually changing the day part of it to "00". That _used_ to work in the old mapping system (though it might mess up your travel stats a bit).

I have some nitpicks with the planner as well: There doesn't seem to be an obvious way to delete a trip, the "cancel" link in the expanded preferences pane goes to 'URL' javascript:$('#trip_preferences').hide() (which gives me a nice white page with content "[object Object]") rather than closing the pane, and it's very confusing UI-wise that the black "add a stop", "preferences" and "collaborate" (and green "hoe can I use this planner?") buttons toggle panes, but the identical looking "map view" button goes to a completely different screen, without an immediately obvious way to get back to the previous view (might be that such a button gets loaded inside the map interface, in which case please disregard that remark, as me not seeing it is just a side effect from blocking everything Google).

3. Posted by Andrea R (Full Member 7 posts) 1y

Agree with Mike. I've been trying to do some mapping today, but running out of patience. It seems the first few stops work smoothly, then you get the constant 'can't find' messages. Can't find Edinburgh, Scotland? Seriously? That was my tipping point! I think I'll give it a rest.

4. Posted by Peter (Admin 5532 posts) 1y

When you get "can't find" messages is the autocomplete showing under the entry box? Do you click on the autocomplete or just hit enter when it looks like it's done it's thing?

This error seems to happen if there's a slight lag connecting to the Google servers to perform the autocomplete. The locations clearly exist and can be found, so it's more of a performance problem than anything else.

There are some fairly significant changes going up to the mapping code this week hopefully which may improve this situation slightly. It may very well also cause a few other bugs that we'll have to work through, but on the whole it will clean up the system and uncomplicate it a little which can only be a good thing.

Mike, when you say you're inserting a stop in the middle of a trip, do you mean in the map view or in the planner view?

Just tested dragging a location and that worked fine for me still. Note, you have to be viewing the trip by itself and not the entire map with all your travels.

Sander, yes there is a button to view in Planner view when you're looking at the map. Deleting at the moment only works through the map view, but should clearly also be in the planner view at some stage.

[ Edit: Edited on 24-Mar-2013, at 02:41 by Peter ]

5. Posted by Utrecht (Moderator 5557 posts) 1y

Quoting Sander

Try picking a date, and then manually changing the day part of it to "00". That _used_ to work in the old mapping system (though it might mess up your travel stats a bit).

That worked in the past indeed, but not anymore. I tried to set the date at 00, or even date and month, but it did not work.
Might be something to consider during the upgrade this week if possible.

6. Posted by Utrecht (Moderator 5557 posts) 1y

Quoting Peter

When you get "can't find" messages is the autocomplete showing under the entry box? Do you click on the autocomplete or just hit enter when it looks like it's done it's thing?

Mike, when you say you're inserting a stop in the middle of a trip, do you mean in the map view or in the planner view?

Just tested dragging a location and that worked fine for me still. Note, you have to be viewing the trip by itself and not the entire map with all your travels.

The can't find messages show up over the entry box actually. I click on the autocomplete in the entry box, so on the location's name itself. It does work after trying several times and it just happens 1 out of 10 or so, but still.

Inserting a stop I do when opening up a specific trip in the map view. The stops are on the left side and I hit the green + button. It then gives me the opportunity to add one, but every now and then it pops up at the bottom anyway. Just clicking a stop randomly and going back to the list seems to work, although I had see stops showing again where did not belong.

Same applies to draggin a location, I view the trip itself and not the entire map with all travels.

Hope this explanation helps a bit;)

Cheers
Michael.

7. Posted by nzhamsta (Respected Member 93 posts) 1y

Hi,

Do your map enhancements week include the ability to edit the curve for all transport types, not just airlines? I have many examples of having to use airlines as my mode of transport so that I can get the line curved in the correct direction when in fact I am on a train, bus etc. It would make my statistics a lot more accurate as well.

Thanks,
Glynn

8. Posted by Peter (Admin 5532 posts) 1y

No, there's not really any noticeable changes to the front end in this batch of code. It's just a lot of restructuring to make it easier for us to do better things. Hopefully the only thing you notice is it being slightly more stable.

The only thing you probably will notice is that some of the location names in the photo galleries might change. This due to them being re-organised somewhat. The latitude / longitude information will not be touched but for some places the name we show in the gallery will be.

Allowing custom curves for other modes of transport probably won't happen to be honest. What we do want to do there is allow overland transport to follow actual routes rather than just as-the-bird-flies. This is a popular request and high on our priority list.

Incidentally, changing the curve for the flights also has no effect on our distance calculation. The distance is always a standard direct calculation. With custom routes added in the future that can be improved however.

9. Posted by Utrecht (Moderator 5557 posts) 1y

Quoting Peter

No,
The only thing you probably will notice is that some of the location names in the photo galleries might change. This due to them being re-organised somewhat. The latitude / longitude information will not be touched but for some places the name we show in the gallery will be.

Is that the reason that when searching for cover photos and also checking featured photos of a city/country, I can nog seem to get the newest ones? Even when searching for a title?

10. Posted by Peter (Admin 5532 posts) 1y

The cover photos search is quite different, but we should be able to use this change to improve that as well actually.