Map Travels Gone

Travel Forums System Talk Map Travels Gone

1. Posted by PassportEnvy (Budding Member 2 posts) 45w Star this if you like it!

Hi,

I am not sure if this is the right place to post but looking for some help or where to request help. I made an account a long time ago but used a different site to update my map. Since that site is gone I decided to come back here and add all of my trips into the map. I love having a visual and Travellerspoint map is awesome! Anyways.... I spend hours updated it all with a ton of trips. Today when I signed on almost all of it was gone! I am perplexed because randomly one trip is still there and another one appeared with about 300 stops in London? Any helpful ideas on how to get the info back or what is wrong so that I don't spend the time doing it again to loose it again!

Thanks!

2. Posted by Sander (Moderator 5418 posts) 45w 1 Star this if you like it!

This seems to be (and hopefully is) merely a bug on the mapping display screen. Your profile lists 15 trips, and your trip stats list the same 15 trips, but your map only shows 3 trips. The third one, "The Big Trip" has 317 stops, with a tripline all over the world, but each stop saying "London, UK".

So probably (hopefully!), the trip information for all fifteen of your trips is still present in the database, and correct, but you managed to hit an unhandled edgecase in the display logic, and that's messing things up.

My best advice at this point is to not make any changes to any trip or stop! That gives the highest chance that the information in the database will remain correct, and for Peter (the admin) to fix whatever bug you're running into. This might take a few days, depending on how tricky the problem is, and how swiftly Peter manages to look into it.

[ Edit: Edited on 07-Jan-2019, at 10:33 by Sander ]

3. Posted by PassportEnvy (Budding Member 2 posts) 45w Star this if you like it!

Thank you so much! Fingers crossed that is what it is. That would be awesome if it can be recovered. I will not edit anything on there and hold tight and wait... I am in no hurry :-) Thank you so much for you response!

4. Posted by Peter (Admin 6821 posts) 45w Star this if you like it!

Looking into this at the moment. I can actually see 15 trips on the map. I'm not seeing "The Big Trip"

Based on that, hopefully it is a display related bug and particularly something to do with caching of the trip data.

5. Posted by Sander (Moderator 5418 posts) 45w Star this if you like it!

Confirmed that I also see 15 trips. None of them have a trip line which looks like "the big trip" did before (that one went from Europe to Africa to South East Asia to Australia / New Zealand to India.

Since none of the current 15 trips go to Australia / New Zealand: PassportEnvy: Did any of your trips actually go there? (Because then something is still missing. And if not, then the caching theory is much more likely, with it possibly being someone else's trip shown under the name "The Big Trip".)

6. Posted by Peter (Admin 6821 posts) 44w Star this if you like it!

Well, it does seem to have been a caching error. I'll need to work out how that could have happened.

The odd thing is that there is no recent trip called "The Big Trip" from any members with those locations. There's another one from last week but it doesn't even include London (or any of those mentioned locations). Definitely some odd behaviour there.

Glad all these 15 trips are back to normal at least.