Issue with updating profile

Travel Forums System Talk Issue with updating profile

1. Posted by road to roam (Travel Guru 1099 posts) 2w Star this if you like it!

I am trying to remove the facebook button (linking icon) from my TP profile. While in edit mode, removing the existing facebook link causes the appropriate field to auto-populate with this example:

looks like https://www.facebook.com/username

I cannot remove this example from the field at all; when I choose Update Profile (with the auto-populated field) the page throws an error which indicates I need to enter a valid url. Removing any url and/or the example from the field - and ultimately my profile - is what I wish to do. My profile still shows a linking facebook button. When I go to the edit mode again, the field has defaulted to a proper facebook url I'm back to where I began.

Everything I've described persists across multiple devices and browsers. I have purged the cache - no luck. I haven't tried turning it off and on again! (IT Crowd reference! )

[ Edit: Edited on 8 Jan 2022, 16:22 GMT by road to roam ]

2. Posted by Sander (Moderator 5712 posts) 2w Star this if you like it!

"looks like https://www.facebook.com/username" is what is known as a "placeholder attribute". It's just a hint to you, not something which is saved in the database. So, when that shows, it means the field is properly empty (no space left or anything).
I can save my profile without any URL in the facebook field (luckily, as I've always kept far away from it).

Are you certain that the error is actually talking about the facebook field, and not one of the other fields which can contain a URL? (i.e. what is the exact error message?)

[ Edit: Edited on 8 Jan 2022, 18:42 GMT by Sander ]

3. Posted by road to roam (Travel Guru 1099 posts) 2w Star this if you like it!

Thank you for the reply, Sander!

Quoting Sander

... https://www.facebook.com/username" is... a "placeholder attribute". It's just a hint to you, not something which is saved in the database. So, when that shows, it means the field is properly empty...

The field for twitter is totally (properly?) empty - no placeholder attribute at all. The palceholder attribute only shows in the field designated for a facebook profile.

Quoting Sander

Are you certain that the error is actually talking about the facebook field, and not one of the other fields which can contain a URL? (i.e. what is the exact error message?)

Yes, it's the field labeled Facebook Profile.

Here is exactly what the red error box says:

Please provide a valid Facebook profile url, located at www.facebook.com

4. Posted by greatgrandmaR (Travel Guru 2131 posts) 2w Star this if you like it!

I don't do twitter, but at some point something got pasted into the twitter place in my profile. I can't delete it completely as it says I need a valid twitter name, but it accepts something that I put in there even if it isn't actually a twitter name.

5. Posted by greatgrandmaR (Travel Guru 2131 posts) 2w Star this if you like it!

I am getting an error posting to the forums

6. Posted by Peter (Admin 7040 posts) 1w Star this if you like it!

I've fixed the error with updating the Facebook profile field. The check was only happening when the value of the field changed. And for some silly reason a blank value was considered invalid. I've fixed that now so you should be able to set it to blank.

I had no trouble removing my Twitter handle.. I don't see a Twitter handle on your profile greatgrandma. I guess you managed to remove it?

The forum posting error should be fixed due to the mail problem being resolved.

7. Posted by road to roam (Travel Guru 1099 posts) 1w Star this if you like it!

Thank you Peter - all sorted now!

8. Posted by greatgrandmaR (Travel Guru 2131 posts) 1w Star this if you like it!

I don't have and never have had a twitter handle. so it isn't in my profile. Where it would turn up is when I would change the parameters of a blog post. There is a space for if you want the blog to go out on twitter. At some point something got pasted into the twitter handle line, and it gives an error message because it was a phrase and not a twitter handle. I don't know where the phrase is lurking but it pops up every now and then in the twitter handle box.